Eclipse Vert.x versions 3.0.0 through 3.5.1 suffer from an HTTP header injection vulnerability.

Source: Eclipse Vert.x 3.5.1 HTTP Header Injection